Re: [AMBER] [EXTERNAL] Error: Incompatible CUDA and GNU versions

From: Chakrabarti, Mayukh \(NIH/NCI\) \[C\] via AMBER <"Chakrabarti,>
Date: Tue, 14 Nov 2023 15:49:17 +0000

Hi, out of curiosity, which version of CMake are you using? I think some older versions of CMake might generate such errors during the configuration process. I have used CMake 3.25+ without issues (at least for the build step).

From: Info via AMBER <>
Date: Tuesday, November 14, 2023 at 10:40 AM
To: <>
Subject: [EXTERNAL] [AMBER] Error: Incompatible CUDA and GNU versions
I am trying to install Amber 22 on a RedHat 8 system with a Quadro RTX 4000 GPU. When I run the configure script I get the error below. My gcc is 8.5.0 which should be compatible with cuda 11.8 ( supports upto gcc 11 )

(amber) [hussaif1.delltower48 build]$ ./ --prefix /home/hussaif1/amber/ --compiler gnu --cuda --install-tests --python --with-python $(which python) --no-miniconda --force-internal-libs="blas;lapack;arpack;netcdf" --no-check-updates --no-apply-updates --no-color-message --save
Starting on Tue Nov 14 09:42:44 2023

.... ( snipped )

-- Found CUDA: /usr/local/cuda-11.8 (found version "11.8")
-- CUDA version 11.8 detected
-- Configuring for SM3.5, SM5.0, SM5.2, SM5.3, SM6.0, SM6.1, SM7.0, SM7.5 and SM8.0
Error: Incompatible CUDA and GNU versions
AMBER mailing list<>
CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender and are confident the content is safe.
AMBER mailing list
Received on Tue Nov 14 2023 - 08:00:02 PST
Custom Search