[AMBER] Ambertools18 tleap scripts not working when run on Ambertools21

From: Daniel Fowles <daniel.fowles.2014.uni.strath.ac.uk>
Date: Thu, 21 Oct 2021 11:21:32 +0000

Hi,

Ive recently updated from Ambertools18 to Ambertools21, and have found that the scripts I used to run tleap and antechamber no longer work even when run on the same systems. I have gone through the manual and cannot see what is going wrong.

Ambertools18 and 21 scripts:
General commands
antechamber -i 0001met.pdb -fi pdb -o gen.mol2 -fo mol2 -c bcc -s 2 -nc -1 2>&1 | tee antechamber.log
parmchk2 -i gen.mol2 -f mol2 -o gen.frcmod 2>&1 | tee parmchk2.log
tleap -f runleap2.sh > tleap.out

runleap2.sh
source oldff/leaprc.ff14SB
source leaprc.gaff
SUS = loadmol2 gen.mol2
check SUS
loadamberparams gen.frcmod
saveoff SUS sus.lib
saveamberparm SUS gen.prmtop gen.inpcrd
quit

Ambertools18 output:
Running: /opt/software/ambertools/intel_2017.1/18.0/bin/bondtype -j full -i ANTECHAMBER_BOND_TYPE.AC0 -o ANTECHAMBER_BOND_TYPE.AC -f ac
Running: /opt/software/ambertools/intel_2017.1/18.0/bin/atomtype -i ANTECHAMBER_AC.AC0 -o ANTECHAMBER_AC.AC -p gaff
Info: Total number of electrons: 10; net charge: 0
Running: /opt/software/ambertools/intel_2017.1/18.0/bin/sqm -O -i sqm.in -o sqm.out
Running: /opt/software/ambertools/intel_2017.1/18.0/bin/am1bcc -i ANTECHAMBER_AM1BCC_PRE.AC -o ANTECHAMBER_AM1BCC.AC -f ac -p /opt/software/ambertools/intel_2017.1/18.0/dat/antechamber/BCCPARM.DAT -s 2 -j 1
Running: /opt/software/ambertools/intel_2017.1/18.0/bin/atomtype -f ac -p bcc -o ANTECHAMBER_AM1BCC.AC -i ANTECHAMBER_AM1BCC_PRE.AC

Ambertools21 output:
Running: /opt/software/ambertools/intel-2020.4/20.0/bin/bondtype -j full -i ANTECHAMBER_BOND_TYPE.AC0 -o ANTECHAMBER_BOND_TYPE.AC -f ac
Running: /opt/software/ambertools/intel-2020.4/20.0/bin/atomtype -i ANTECHAMBER_AC.AC0 -o ANTECHAMBER_AC.AC -p gaff
Info: Total number of electrons: 11; net charge: -1
Info: The number of electrons is odd (11).
      Please check the total charge (-nc flag) and spin multiplicity (-m flag).
Running: /opt/software/ambertools/intel-2020.4/20.0/bin/sqm -O -i sqm.in -o sqm.out
/opt/software/ambertools/intel-2020.4/20.0/bin/wrapped_progs/antechamber: Fatal Error!
Cannot properly run "/opt/software/ambertools/intel-2020.4/20.0/bin/sqm -O -i sqm.in -o sqm.out".
Cannot open file (gen.mol2) with mode (r).
No such file or directory

Any help in what is going wrong would be much appreciated, thanks.
_______________________________________________
AMBER mailing list
AMBER.ambermd.org
http://lists.ambermd.org/mailman/listinfo/amber
Received on Thu Oct 21 2021 - 04:30:03 PDT
Custom Search