RE: AMBER: compilation problem

From: Ross Walker <ross.rosswalker.co.uk>
Date: Sat, 30 Aug 2008 11:33:13 -0700

Hi John,

 

What are the actual error messages you are seeing? - I.e. all of the output
printed to the screen when you run configure_at?

 

Ross

 

From: owner-amber.scripps.edu [mailto:owner-amber.scripps.edu] On Behalf Of
john smith
Sent: Saturday, August 30, 2008 4:51 AM
To: amber
Subject: AMBER: compilation problem

 

Hi everyone,

I am installing AMBER 10 with Sun Studio 12 compilers on AMD64 bit machine
having Solaris OS.

But the forllowing part of Configure_at is giving me the problem
*********
# Here, just to get going, hard-wire g77
fc=g77
echo "Mopac and resp will be compiled with g77"

fflags="-O0"
foptflags="-O3"

if [ $gnucompat = "yes" ]; then
gnucompatibility="-fsecond-underscore"
else
gnucompatibility="-fno-second-underscore"
fi
fflags="$fflags $gnucompatibility"
foptflags="$foptflags $gnucompatibility"

echo "Testing the g77 compiler:"
echo " $fc $fflags -o testp$suffix testp.f"
$fc $fflags -o testp testp.f
./testp | grep "testing a Fortran program" > /dev/null
status=$?

if [ "$status" -gt 0 ]; then
echo "Unable to compile a Fortran program using $fc $fflags"
echo "We will be unable to compile mopac or resp"
g77='noG77'
else
echo "OK"
fi
/bin/rm -f testp.f testp.o testp$suffix
********************************
This I solved by some google and Sun microsystems- forums search by using
the following script
******************

# Here, just to get going, hard-wire f90


   fc=f90


   echo "Mopac and resp will be compiled with f90"





   fflags="-O0"


   foptflags="-fast"









echo "Testing the f90 compiler:"


echo " $fc $fflags -o testp$suffix testp.f"


$fc $fflags -o testp testp.f


./testp | grep "testing a Fortran program" > /dev/null


status=$?









if [ "$status" -gt 0 ]; then


   echo "Unable to compile a Fortran program using $fc $fflags"


   echo "We will be unable to compile mopac or resp"


   g77='noG77'


else






   echo "OK"


fi


/bin/rm -f testp.f testp.o testp$suffix


************************





But it didnt work. no makefile is generated at the end





please someone help me out of this.






Thanks in advance

 



-----------------------------------------------------------------------
The AMBER Mail Reflector
To post, send mail to amber.scripps.edu
To unsubscribe, send "unsubscribe amber" (in the *body* of the email)
      to majordomo.scripps.edu
Received on Sun Aug 31 2008 - 06:08:17 PDT
Custom Search