Re: [AMBER] 02_03.rms problem

From: simon chapman <rowanlodge19.gmail.com>
Date: Mon, 5 Nov 2018 22:09:42 +0000

Hello again Dan...Sorry, might not have made the problem clear. I am
executing the xmgrace command *after* the cpptraj command,not before.
xmgrace isn't part of the input script.

Attached screen shot shows the sequence. It does look like the cpptraj
script isn't generating the 02_03.rms file.

BW Simon

On Mon, 5 Nov 2018 at 14:40, Daniel Roe <daniel.r.roe.gmail.com> wrote:

> Hi,
>
> The issue is that you're attempting to execute xmgrace prior to the
> actual trajectory processing run, so 02_03.rms is not generated and
> the command fails. Just remove the 'xmgrace' command from your input
> script and things should work.
>
> I should probably disable those kinds of commands when cpptraj is not
> being run interactively.
>
> -Dan
> On Sat, Nov 3, 2018 at 10:50 AM simon chapman <rowanlodge19.gmail.com>
> wrote:
> >
> > Hello Daniel, thank you for the prompt reply.
> >
> > I'm using cpptraj V17.00 and AMBER16
> >
> > The command is: (..$) cpptraj -p prmtop -i rmsd.cpptraj &> cpptraj.log
> > Where the rmsd.rms script is: trajin 02_Heat.mdcrd
> >
> >
> >
> > trajin 03_Prod.mdcrd
> >
> >
> >
> > reference 01_Min.rst
> >
> >
> >
> > autoimage
> >
> >
> >
> > rms reference mass out 02_03.rms time 2.0 :0
> >
> >
> >
> >
> >
> >
> > Followed by (..$) xmgrace 02_03.rms
> >
> > This prompts the reply " Can't stat file 02_03.rms" and obviously no
> > 02_03.rms file appears in my working directory. I've tried this quite a
> > few times now, with the same result. I'm baffled why it worked at the
> first
> > attempt to follow Tutorial B0, but has failed on every occasion since...
> >
> > Best wishes Simon
> >
> >
> >
> >
> > On Sat, 3 Nov 2018 at 13:42, Daniel Roe <daniel.r.roe.gmail.com> wrote:
> >
> > > Hi,
> > >
> > > What version of cpptraj are you using, what is your exact cpptraj
> input and
> > > what output do you get?
> > >
> > > -Dan
> > >
> > > On Sat, Nov 3, 2018 at 5:08 AM simon chapman <rowanlodge19.gmail.com>
> > > wrote:
> > >
> > > > Hello. I successfully followed Tutorial B0 (MD simulation of a simple
> > > > dipeptide), and obtained Temp, Energy, RMSD plots. Very pleased.
> > > >
> > > > But, running the same simulation again, the cpptraj script wouldn't
> > > produce
> > > > an 02_03.rms flie. Consequently, no plots possible.
> > > >
> > > > I tried simulations with two other molecules (1kf1.pdb and 1fsc.pdb).
> > > Both
> > > > ran successfully, producing all the expected files, but again, no
> > > 02_03.rms
> > > > file showing after the cpptraj script command.
> > > >
> > > > I'm reasonably computer-literate, but not 100% IT background: I'm a
> > > > molecular biologist, not a mathematician!
> > > >
> > > > Thanks in advance for any help Simon
> > > > _______________________________________________
> > > > AMBER mailing list
> > > > AMBER.ambermd.org
> > > > http://lists.ambermd.org/mailman/listinfo/amber
> > > >
> > > _______________________________________________
> > > AMBER mailing list
> > > AMBER.ambermd.org
> > > http://lists.ambermd.org/mailman/listinfo/amber
> > >
> > _______________________________________________
> > AMBER mailing list
> > AMBER.ambermd.org
> > http://lists.ambermd.org/mailman/listinfo/amber
>
> _______________________________________________
> AMBER mailing list
> AMBER.ambermd.org
> http://lists.ambermd.org/mailman/listinfo/amber
>


_______________________________________________
AMBER mailing list
AMBER.ambermd.org
http://lists.ambermd.org/mailman/listinfo/amber


Capture.PNG
(image/png attachment: Capture.PNG)

Received on Mon Nov 05 2018 - 14:30:03 PST
Custom Search