Re: [AMBER] Boost not linking when compiling on Mac

From: Gustaf Olsson <gustaf.olsson.lnu.se>
Date: Wed, 2 May 2018 06:44:30 +0000

This is the direct output by running antechamber without correct input, I intentionally ignored to set “ac_input” and “input” which I used before to run multiple structures in sequence. As you can se, $AMBERHOME and $AMBER_PREFIX is set

guolaa$ echo $AMBERHOME $AMBER_PREFIX
/Users/guolaa/SOFTWARE/amber18 /Users/guolaa/SOFTWARE/amber18
guolaa$ antechamber -i $ac_input/$input.pdb -fi pdb -o $input.prepi -fo prepi -c bcc -rn $INP

Welcome to antechamber 17.3: molecular input file processor.

/Users/guolaa/SOFTWARE/amber18/bin/to_be_dispatched/antechamber: Fatal Error!
Number of arguments is odd - arguments must come in pairs.
Use antechamber -h for command-line syntax.
guolaa$ which antechamber
/Users/guolaa/SOFTWARE/amber18/bin/antechamber

Antechamber does point to the correct location however the error for antechamber refers to “to_be_dispatched”. I can try to also recreate the sqm error though it won’t be today. I’ll attach a screendump so you can se that this is what is really happening.

[cid:37AE87DB-C9CE-4235-8308-E3BEF49EF78A.lnu.se]

Best regards
// Gustaf


On 27 Apr 2018, at 20:12, Scott Brozell <sbrozell.rci.rutgers.edu<mailto:sbrozell.rci.rutgers.edu>> wrote:

Hi,

Regarding antechamber error reporting and ignoring the boost topic,
is it reproducible that when sqm fails an incorrect path is reported ?
Please send (me) verbose and verbatim details, eg, copy-n-pasted proof
and input files so that i can try to reproduce the issue.

I cannot see how sqm could end up in to_be_dispatched.
For the record, bin/to_be_dispatched/antechamber can be run directly;
if AMBERHOME is not set then it produces an error message else it
runs normally.

scott

On Fri, Apr 27, 2018 at 06:37:05AM +0000, Gustaf Olsson wrote:
So, this is going to be an interesting piece of mail again *insert-smile-here*. It turned out that poorly configured input was the culprit in the sqm related issue in the parallell version of amber. Now, this is where it gets strange, when antechamber failed on sqm it did report the ???to_be_dispatched??? sqm version as being unable to execute HOWEVER:

which sqm
/SOFTWARE/amber18/bin/sqm
echo $AMBERHOME
SOFTWARE/amber18

Of course $AMBERHOME is set, this is why I reacted. Something seemed off and something is strange, when sqm works the correct version runs though when it failed the incorrect version was reported as being the issue.

2018-04-26 11:43 GMT+02:00 Gustaf Olsson <gustaf.olsson.lnu.se<mailto:gustaf.olsson.lnu.se><mailto:gustaf.olsson.lnu.se>>:

I ignored BOOST and compiled serial version, seems to have been working
fine for all purposes investigated yesterday.

Compiled the parallell version today and running antechamber received an
error in the lines of:

../to-be-dispatched/bin/sqm -O -i sqm.in -o sum.out
Could not be executed..

Sadly I did not save the exact error so this is just a rough guess. I am
recompiling the serial version now and I???ll try to recreate the issue later
on.

_______________________________________________
AMBER mailing list
AMBER.ambermd.org<mailto:AMBER.ambermd.org>
http://lists.ambermd.org/mailman/listinfo/amber





_______________________________________________
AMBER mailing list
AMBER.ambermd.org
http://lists.ambermd.org/mailman/listinfo/amber


error.png
(image/png attachment: error.png)

Received on Wed May 02 2018 - 00:00:02 PDT
Custom Search