Re: [AMBER] Fwd: GPU pmemd.cuda runs very slow (3ns/day)???

From: Chinh Su Tran To <chinh.sutranto.gmail.com>
Date: Thu, 4 Jun 2015 18:58:08 +0800

Dear Prof. Monard,

The slow GPU run is for the eq.in (which I stored every 50000 steps). The
attached file previously is the "heating" results --the stage before
running equilibration.
I attached the results of eq here. Sorry for the inconvenience.

Thanks.
CS

On Thu, Jun 4, 2015 at 5:52 PM, Gerald Monard <
Gerald.Monard.univ-lorraine.fr> wrote:

> Hi,
>
> I'm not sure that your numbers are that strange given the file that
> you've put in attachment. It says:
> ntpr = 100, ntwx = 100, ntwr = 1000,
> (in contracdiction with your saying below, are you sure that you use the
> right mdin?)
> and NATOM=265294
>
> So your system is rather big and your save every 100 steps
> (recommendation for GPU run is to save at least every 1000 steps,
> meaning ntpr, ntwx and ntwr should be >= 1000). With a GTX760 card, that
> doesn't seem strange to me. Try increasing ntwx and ntpr, and see how it
> goes.
>
> Gerald.
>
>
> On 06/04/2015 10:13 AM, Chinh Su Tran To wrote:
> > Dear AMBER users, especially GPU experts,
> >
> > I am running a 432-residue protein in explicit (amber12) on GPU
> (installed
> > in a desktop Ubuntu 12.04, 64bit). What confuses me is that it runs so
> slow
> > (and I think it should not have been).
> >
> > My mdinfo (equilibrium for 20ns) says:
> >
> >
> ------------------------------------------------------------------------------
> > | Current Timing Info
> > | -------------------
> > | Total steps : 10000000 | Completed : 50000 | Remaining : 9950000
> > |
> > | Average timings for last 50000 steps:
> > | Elapsed(s) = 2803.57 Per Step(ms) = 56.07
> > | ns/day = 3.08 seconds/ns = 28035.65
> > |
> > | Average timings for all steps:
> > | Elapsed(s) = 2803.57 Per Step(ms) = 56.07
> > | ns/day = 3.08 seconds/ns = 28035.65
> > |
> > |
> > | Estimated time remaining: 155.0 hours.
> >
> ------------------------------------------------------------------------------
> >
> > The rate of 3ns/day for GPU (pmemd.cuda) may be not right here.
> >
> > When I checked "nvidia-smi" for the GPU info, it gives:
> >
> > +------------------------------------------------------+
> >
> > | NVIDIA-SMI 346.72 Driver Version: 346.72
> > |
> >
> |-------------------------------+----------------------+----------------------+
> > | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr.
> > ECC |
> > | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util
> Compute
> > M. |
> >
> |===============================+======================+======================|
> > | 0 GeForce GTX 760 Off | 0000:01:00.0 N/A |
> > N/A |
> > | 80% 73C P0 N/A / N/A | 1267MiB / 2047MiB | N/A
> > Default |
> >
> +-------------------------------+----------------------+----------------------+
> >
> >
> >
> +-----------------------------------------------------------------------------+
> > | Processes: GPU
> > Memory |
> > | GPU PID Type Process name
> > Usage |
> >
> |=============================================================================|
> > | 0 C+G Not
> > Supported |
> >
> +-----------------------------------------------------------------------------+
> >
> > May I ask if there is anything wrong about the card or the system?
> > Or if I made any mistakes during the set-up?
> >
> > Attached is the results from the heating stage, and it seems ok.
> >
> > Thank you. Please help.
> >
> > My input file (eq.in):
> > &cntrl
> > imin=0, irest=1, ntx=7,
> > ntxo=2
> > ig=-1, ntb=2,
> > pres0=1.0, ntp=1, taup=2.0,
> > cut=10.0,
> > ntr=0, ntc=2, ntf=2,
> > tempi=300.0, temp0=300.0,
> > ntt=3, gamma_ln=1.0,
> > nstlim=10000000, dt=0.002,
> > ntpr=50000, ntwx=50000, ntwr=50000
> > /
> >
> > Thanks and regards,
> > Chinh
> >
> >
> >
> > _______________________________________________
> > AMBER mailing list
> > AMBER.ambermd.org
> > http://lists.ambermd.org/mailman/listinfo/amber
> >
>
> --
>
> ____________________________________________________________________________
>
> Prof. Gerald MONARD
> SRSMC, Université de Lorraine, CNRS
> Boulevard des Aiguillettes B.P. 70239
> F-54506 Vandoeuvre-les-Nancy, FRANCE
>
> e-mail : Gerald.Monard.univ-lorraine.fr
> tel. : +33 (0)383.684.381
> fax : +33 (0)383.684.371
> web : http://www.monard.info
>
>
> ____________________________________________________________________________
>
>
> _______________________________________________
> AMBER mailing list
> AMBER.ambermd.org
> http://lists.ambermd.org/mailman/listinfo/amber
>


_______________________________________________
AMBER mailing list
AMBER.ambermd.org
http://lists.ambermd.org/mailman/listinfo/amber


Received on Thu Jun 04 2015 - 04:00:03 PDT
Custom Search