Re: [AMBER] AmberTools 1.5 gnu compilation fails under FC15

From: Ben Roberts <ben.roberts.geek.nz>
Date: Mon, 20 Jun 2011 16:12:14 -0400

Hi Pietro,

On 20/6/2011, at 4:11 p.m., pamodeo wrote:

> Hi all,
>
> I've just tried to compile AT 1.5, but the compilation stops after some
> warnings and one error, all apparently related to type mismatch
> problems.
>
> The last part of the comp. log is reported below.
> The workstation presently runs Fedora 15 with:
>
> kernel: 2.6.38.8-32.fc15.x86_64 (SMP)
> gcc: 4.6.0 20110530 (Red Hat 4.6.0-9)
> MKL: 12.0.1.107 (em64t)
>
> Before compiling, I downloaded and applied the most recent patches for
> AT 1.5 (patches 1-7) and Amber 11 (patches 1-12). The AT 1.5
> installation was performed on top of an existing AmberTools 1.4
> directory tree, but, before the new installation, a "make clean" command
> was issued, and the previous content of the $AMBERHOME/lib dir was
> manually removed.

This problem has recently come to our attention as developers, and a bunch of us are working on patches. It seems that things that were acceptable (if not necessarily recommended) in older versions of the GNU Fortran compilers are verboten under GCC 4.6.

If you would like to compile AmberTools (and/or Amber) before the necessary patches are released, you'll need to use an earlier version of the GNU compilers.

Best,

Ben

-- 
For greater security, I support S/MIME encryption.





_______________________________________________
AMBER mailing list
AMBER.ambermd.org
http://lists.ambermd.org/mailman/listinfo/amber


Received on Mon Jun 20 2011 - 13:30:20 PDT
Custom Search