Re: [AMBER] segmentation fault

From: Jagdeesh C <jagc666.gmail.com>
Date: Thu, 22 Jul 2010 15:21:15 +0530

Dear Professor Case,

I upgraded and installed everything again (amber 10). Then I ran the file
you had provided earlier >Run.dhfr.min_prcg (attached)

1) OS Ubuntu 10.04

2) Compiler gfortran -v
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu
4.4.3-4ubuntu5' --with-bugurl=file:///usr/share/doc/gcc-4.4/README.Bugs
--enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --enable-shared
--enable-multiarch --enable-linker-build-id --with-system-zlib
--libexecdir=/usr/lib --without-included-gettext --enable-threads=posix
--with-gxx-include-dir=/usr/include/c++/4.4 --program-suffix=-4.4
--enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-plugin
--enable-objc-gc --enable-targets=all --disable-werror --with-arch-32=i486
--with-tune=generic --enable-checking=release --build=i486-linux-gnu
--host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5)

3) I ran the program ./Run.dhfr.min_prcg and I got the same thing again.

/usr/local/amber10/test/dhfr# ./Run.dhfr.min_prcg
Segmentation fault
  ./Run.dhfr.min_prcg: Program error

Is the present version of gcc/gfortran okay? What can be the reason for this
error ??

Best Regards,
Jagdeesh



On Tue, Jul 6, 2010 at 11:07 PM, David A. Case <case.biomaps.rutgers.edu>wrote:

>
> On Tue, Jul 06, 2010, Jagdeesh C wrote:
>
> > Thank you Professor Case. I have followed what you have mentioned.
> >
> > 1) I ran the attached file and here is the output I got
> >
> > ./Run.dhfr.min_prcg
> > Segmentation fault
> > ./Run.dhfr.min_prcg: Program error
>
> OK...that means the result isn't anything special about your system.
>
> > 3) Compiler/Compiler version
> > gfortran
> > Thread model: posix
> > gcc version 4.1.2 20080704 (Red Hat 4.1.2-44)
> >
> > Os CentOS release 5.3
>
> I think we can still access a machine with gcc4.1.2 to try to reproduce
> this. But you might really think about upgrading to gcc44, which RedHat
> now has as a package. There are certainly other parts of sander that are
> known to fail with that version of gcc/gfortran.
>
> Thanks again for the report.
>
> ...dac
>
> _______________________________________________
> AMBER mailing list
> AMBER.ambermd.org
> http://lists.ambermd.org/mailman/listinfo/amber
>


_______________________________________________
AMBER mailing list
AMBER.ambermd.org
http://lists.ambermd.org/mailman/listinfo/amber


Received on Thu Jul 22 2010 - 03:00:05 PDT
Custom Search