RE: AMBER: Error while compiling Amber

From: Ross Walker <ross.rosswalker.co.uk>
Date: Sat, 9 Feb 2008 09:58:59 -0800

Hi Lili,
 
You should check the manual for mpich2 - this version of mpi requires a
demon to be running (in this case called MPD) on all of the nodes on which
you want the code to run. This typically means setting up a machine file or
equivalent that is read by mpd.
 
If you just want to run this on the local machine to which you are logged in
then you can try.
 
mpd &
export DO_PARALLEL='mpirun =np 4'
make test.parallel
 
All the best
Ross

/\
\/
|\oss Walker

| Assistant Research Professor |
| San Diego Supercomputer Center |
| Tel: +1 858 822 0854 | EMail:- ross.rosswalker.co.uk |
| http://www.rosswalker.co.uk <http://www.rosswalker.co.uk/> | PGP Key
available on request |

Note: Electronic Mail is not secure, has no guarantee of delivery, may not
be read every day, and should not be used for urgent or sensitive issues.

 


  _____

From: owner-amber.scripps.edu [mailto:owner-amber.scripps.edu] On Behalf Of
Lili Peng
Sent: Friday, February 08, 2008 17:52
To: amber.scripps.edu
Subject: Re: AMBER: Error while compiling Amber


Hi Dr. Case,
 
Thank you for your help. I added the parser.c file, and the serial
compilation of AMBER worked.
 
... Though I have another problem now. It's about compiling Sander in
parallel. Although I've searched the mailing list archives extensively,
none of what's been discussed addresses the issue. It has to do with the
make install function, and I'm trying to do a test run of sander. I have
already compiled my MPI library (the MPICH2 version). Here's my input code
(in bold) and the errors:
 
$ export AMBERHOME="/nas/lpeng/src/amber9"
$ export MPI_HOME="/nas/lpeng/opt"
$ export CC=icc
$ export FC=ifort
$ ./configure --prefix=/nas/lpeng/opt CC=$CC FC=$FC
$ make
$ make install
$ ./configure -mpich2 -p4 -static ifort_ia32
$ make parallel
 
... and Amber 9 was compiled successfully. Following the compiling
instructions, I continued on..
 
$ export DO_PARALLEL="/nas/lpeng/src/mpich2-1.0.6p1/bin/mpirun -np 4"
$ make test.sander
 
Then I get the error:
 
make: *** No rule ot make target 'test.sander'. Stop.
 
I also tried:
 
$ make test.parallel
 
..and receive in response:
 
export TESTsander=/nas/lpeng/src/amber9/exe/sander.MPI/exe/sander.MPI; make
test.sander.BASIC
make[1]: Entering directory `/nas/lpeng/src/amber9/test'
cd dmp; ./Run.dmp
This test not set up for parallel
 cannot run in parallel with #residues < #pes
cd adenine; ./Run.adenine
This test not set up for parallel
 cannot run in parallel with #residues < #pes
==============================================================
cd cytosine; ./Run.cytosine
mpiexec_granite.ucsd.edu: cannot connect to local mpd
(/tmp/mpd2.console_lpeng); possible causes:
  1. no mpd is running on this host
  2. an mpd is running but was started without a "console" (-n option)
In case 1, you can start an mpd on this host with:
    mpd &
and you will be able to run jobs just on this host.
For more details on starting mpds on a set of hosts, see
the MPICH2 Installation Guide.
  ./Run.cytosine: Program error
make[1]: *** [test.sander.BASIC] Error 1
make[1]: Leaving directory `/nas/lpeng/src/amber9/test'
make: *** [test.sander.BASIC.MPI] Error 2
 
Do you have any leads on what is causing this to occur? Any input from your
end would be greatly appreciated.
 
Sincerely,
Lili
 
 
On 07/02/2008, David A. Case <case.scripps.edu> wrote:

On Thu, Feb 07, 2008, Lili Peng wrote:
>
>
> *$ ./configure -p4 ifort_x86_64*

What kind of machine are you compiling on? On the one hand, you say "-p4"
(which is for Pentium IV), yet you also say x86_64, which is a very
different
type of architecture.

Typing "uname -m" should give you the information you need. Then choose the
correct options.

>
> *$ ./configure -p4 ifort_ia32 *
> yacc parser.y
> make[2]: execvp: yacc: Permission denied

It looks like you got a lot further this time, so my guess is that you are
on
an ia32 (aka i386 aka i686) system. You should see that sander and lots of
other programs have been compiled. For the above problem:

First, try "which yacc" and try to find out if it exists, and if so, why
   you are getting permission denied.

Second, try "which bison": if it looks like you have permissions to run
bison,
add the line

YACC = bison -y

to your config.h file (in $AMBERHOME/src).

Or, if neither work, put the attached parser.c file in
$AMBERHOME/src/leap/src/leap, and try again.

....dac







-----------------------------------------------------------------------
The AMBER Mail Reflector
To post, send mail to amber.scripps.edu
To unsubscribe, send "unsubscribe amber" to majordomo.scripps.edu
Received on Sun Feb 10 2008 - 06:07:41 PST
Custom Search