RE: AMBER: Building parallel Amber 9.0

From: Ross Walker <ross.rosswalker.co.uk>
Date: Wed, 15 Aug 2007 07:26:36 -0700

Dear John,
 
You need to compile open MPI with the same Fortran compiler as you use to
compile Amber. I suspect that you didn't manually specify FC= when building
openMPI and so it used either g77 or gfortran.
 
All the best
Ross

/\
\/
|\oss Walker

| HPC Consultant and Staff Scientist |
| San Diego Supercomputer Center |
| Tel: +1 858 822 0854 | EMail:- ross.rosswalker.co.uk |
| http://www.rosswalker.co.uk <http://www.rosswalker.co.uk/> | PGP Key
available on request |

Note: Electronic Mail is not secure, has no guarantee of delivery, may not
be read every day, and should not be used for urgent or sensitive issues.

 


  _____

From: owner-amber.scripps.edu [mailto:owner-amber.scripps.edu] On Behalf Of
Beale, John
Sent: Wednesday, August 15, 2007 05:22
To: amber.scripps.edu
Subject: AMBER: Building parallel Amber 9.0


I am trying to build a parallel install of Amber 9 on an SGI Linux system
with 4 processors. I properly installed the open-mpi utility. I use the
"configure" with "ifort_ia32", which I think is appropriate for my system. I
then do a "make clean" as recommended. When I try to install the package, I
get the following error messages (many of these):
 
force.o (.text + 0x273b):In function 'force_':
:undefined reference to 'mpi_bcast_'
 
.........many such complaints
 
make [1]: *** [sander.MPI] Error 1
make [1]: Leaving directory '....../src/sander'
make: *** [parallel] Error 2
 
 
This seems to point to a problem with open-mpi, but that package seemed to
install without errors. Can someone point me in the right direction?
 
Thanks!
 
John Beale




-----------------------------------------------------------------------
The AMBER Mail Reflector
To post, send mail to amber.scripps.edu
To unsubscribe, send "unsubscribe amber" to majordomo.scripps.edu
Received on Sun Aug 19 2007 - 06:07:07 PDT
Custom Search