RE: AMBER: problem in installing amber9

From: Ross Walker <ross.rosswalker.co.uk>
Date: Wed, 13 Jun 2007 08:25:19 -0700

Dear Henk,
 
I'm glad you managed to get sander working. For pmemd can you try the
following:
 
nm /usr/local/topspin/mpi/mpich/lib64/libmpichf90_i.so | grep mpi_bcast
 
and if that doesn't show anything then:
 
nm /usr/local/topspin/mpi/mpich/lib64/libmpich.so | grep mpi_bcast
 
I am guessing that the symbols defined in the mpich libraries will either
have no trailing underscores or two trailing underscores, as opposed to the
single trailing underscore that the linker is looking for below.
 
If the grep above shows no final underscore then on the F90FLAGS line and
the LOADFLAGS line in config.h append:
 
-assume nounderscore
 
if the grep above shows two trailing underscores then try adding:
 
-assume 2underscores
 
Then make clean, make
 
Hopefully this will then link okay.
 
All the best
Ross
 
/\
\/
|\oss Walker

| HPC Consultant and Staff Scientist |
| San Diego Supercomputer Center |
| Tel: +1 858 822 0854 | EMail:- ross.rosswalker.co.uk |
| http://www.rosswalker.co.uk <http://www.rosswalker.co.uk/> | PGP Key
available on request |

Note: Electronic Mail is not secure, has no guarantee of delivery, may not
be read every day, and should not be used for urgent or sensitive issues.
 


  _____

From: owner-amber.scripps.edu [mailto:owner-amber.scripps.edu] On Behalf Of
Henk Meij
Sent: Wednesday, June 13, 2007 06:41
To: amber.scripps.edu
Subject: Re: AMBER: problem in installing amber9


(reposting, archive does not show this response arrived...)

Ross, thanks for all your help. i made links for libvapi and libmosal in
lib64 pointing to the /usr/local/topspin/lib64 copies. we have binaries!
way confusing, but we're there.

pmemd however still fails. same environment. do you have any clues on were
all these undefined reference are hiding?

-Henk


[root.swallowtail src]# ldd /share/apps/amber/9_ifort/exe/sander.MPI

        libmpichf90_i.so =>
/usr/local/topspin/mpi/mpich/lib64/libmpichf90_i.so (0x0000002a95576000)

        libmpich_i.so => /usr/local/topspin/mpi/mpich/lib64/libmpich_i.so
(0x0000002a956d4000)

        libmpichfsup_i.so =>
/usr/local/topspin/mpi/mpich/lib64/libmpichfsup_i.so (0x0000002a978f3000)

        libmpich.so => /usr/local/topspin/mpi/mpich/lib64/libmpich.so
(0x0000002a979f6000)

        libvapi.so => /usr/local/topspin/lib64/libvapi.so
(0x0000002a99c17000)

        libmosal.so => /usr/local/topspin/lib64/libmosal.so
(0x0000002a99d37000)

        libpthread.so.0 => /lib64/tls/libpthread.so.0 (0x0000003684400000)

        libdl.so.2 => /lib64/libdl.so.2 (0x0000003684000000)

        libvml.so => /share/apps/intel/cmkl/9.1/lib/em64t/libvml.so
(0x0000002a99e47000)

        libmkl_lapack.so =>
/share/apps/intel/cmkl/9.1/lib/em64t/libmkl_lapack.so (0x0000002a99fdc000)

        libmkl.so => /share/apps/intel/cmkl/9.1/lib/em64t/libmkl.so
(0x0000002a9a74a000)

        libguide.so => /share/apps/intel/cmkl/9.1/lib/em64t/libguide.so
(0x0000002a9a8ca000)

        libm.so.6 => /lib64/tls/libm.so.6 (0x00000034d3600000)

        libc.so.6 => /lib64/tls/libc.so.6 (0x0000003683b00000)

        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x0000003687b00000)

        libg2c.so.0 => /usr/lib64/libg2c.so.0 (0x0000002a9aa2d000)

        /lib64/ld-linux-x86-64.so.2 (0x0000003683900000)



[root.swallowtail pmemd]# /share/apps/amber/9_ifort/exe/sander.MPI --help

Can't read MPIRUN_HOST



[root.swallowtail pmemd]# ./configure linux_em64t ifort mpich



Intel ifort compiler found; version information:

Version 9.1

configure assumes Intel MKL is installed in /share/apps/intel/cmkl/9.1

File config_data/fft.pubfft being used...

File config_data/linux_em64t.ifort being used...

File config_data/interconnect.mpich being used...

configure assumes mpich files are in /usr/local/topspin/mpi/mpich.

PMEMD Configurate successfully completed.



[root.swallowtail pmemd]# make install > /tmp/log 2>&1



first error:

IPO link: can not find -lmpich

ifort: error: problem during multi-file optimization compilation (code 1)



changed config.h

#MPI_LIBDIR = $(MPI_HOME)/lib

MPI_LIBDIR = $(MPI_HOME)/lib64



...remaking - no errors this far...

/lib/cpp -traditional -P -I/usr/local/topspin/mpi/mpich/include -DPUBFFT
-DMPI -DSLOW_NONBLOCKING_MPI -DDIRFRC_EFS -DDIRFRC_COMTRANS -DDIRFRC_NOVEC
-DMKL -DFFTLOADBAL_2PROC erfcfun.fpp erfcfun.f90

ifort -c -auto -tpp7 -xW -ip -O3 erfcfun.f90

ifort -o pmemd gbl_constants.o gbl_datatypes.o state_info.o file_io_dat.o
parallel_dat.o mdin_ctrl_dat.o mdin_ewald_dat.o prmtop_dat.o inpcrd_dat.o
dynamics_dat.o img.o parallel.o pme_direct.o pme_recip.o pme_fft.o fft1d.o
bspline.o pme_force.o pbc.o nb_pairlist.o cit.o dynamics.o bonds.o angles.o
dihedrals.o runmd.o loadbal.o shake.o runmin.o constraints.o axis_optimize.o
gb_ene.o veclib.o gb_force.o timers.o pmemd_lib.o runfiles.o file_io.o
bintraj.o pmemd_clib.o pmemd.o random.o degcnt.o erfcfun.o nmr_calls.o
nmr_lib.o get_cmdline.o master_setup.o alltasks_setup.o pme_setup.o
ene_frc_splines.o nextprmtop_section.o
-L/share/apps/intel/cmkl/9.1/lib/em64t -lmkl_em64t -lpthread
-L/usr/local/topspin/mpi/mpich/lib64 -lmpich -limf -lsvml
-Wl,-rpath=/share/apps/intel/cmkl/9.1/lib/em64t:/share/apps/intel/mpi/3.0.04
3/lib64:/share/apps/intel/fce/9.1.043/lib:/share/apps/intel/cce/9.1.047/lib:
/opt/lava/6.1/linux2.6-glibc2.3-ia32e/lib:/opt/lava/6.1/linux2.6-glibc2.3-ia
32e/lib:/share/

 apps/openmpi-1.2/lib

parallel_dat.o(.text+0x40): In function `parallel_dat_mod_mp_mexit_':

: undefined reference to `mpi_group_free_'

parallel_dat.o(.text+0x53): In function `parallel_dat_mod_mp_mexit_':

: undefined reference to `mpi_finalize_'

parallel_dat.o(.text+0xad): In function `parallel_dat_mod_mp_mexit_':

: undefined reference to `mpi_abort_'

mdin_ctrl_dat.o(.text+0x842a): In function
`mdin_ctrl_dat_mod_mp_bcast_mdin_ctrl_dat_':

: undefined reference to `mpi_bcast_'

mdin_ctrl_dat.o(.text+0x8451): In function
`mdin_ctrl_dat_mod_mp_bcast_mdin_ctrl_dat_':

: undefined reference to `mpi_bcast_'



-these undefined references continue for awhile, then-



/share/apps/intel/cmkl/9.1/lib/em64t/libmkl_em64t.a(vml_threading_service.o)
(.text+0x2b): In function `mkl_vml_service_threader_s_min':

: undefined reference to `omp_in_parallel'

/share/apps/intel/cmkl/9.1/lib/em64t/libmkl_em64t.a(vml_threading_service.o)
(.text+0x167): In function `CalculateLogicConsts':

: undefined reference to `omp_get_num_procs'



- and lots of those -



btw,



[root.swallowtail pmemd]# mpif90 -link_info

ln -s /usr/local/topspin/mpi/mpich//include/mpif.h mpif.h

ifort -I/usr/local/topspin/mpi/mpich//include
-L/usr/local/topspin/mpi/mpich//lib -lmpichf90_i -lmpich_i -lmpichfsup_i -L
/usr/local/topspin/lib64 -L /usr/local/topspin/mpi//mpich/lib64 -lmpich
-lvapi -lmosal -Bdynamic -lpthread -ldl

rm mpif.h



so i now made a link in

/usr/local/topspin/mpi/mpich

pointing lib/ to lib64/

did not help



Hi Syed,



I think you are seeing the same problem that is mentioned in some of the

links to the amber mailing list archive. I don't think we have ever been

able to locate what causes this problem however...



One option would be to try changing the c compiler. If you have the Intel

compilers installed (ifort / icc) then try, assuming you have an x86_64

machine and the 64 bit version of the compilers (fce/cce) and OS installed:



./configure -static -nopar ifort_x86_64



Then edit config.h and change gcc to icc and g++ to icpc.



Then make clean, make



See if xleap then works in this situation.



All the best

Ross



/\

\/

|\oss Walker



| HPC Consultant and Staff Scientist |

| San Diego Supercomputer Center |

| Tel: +1 858 822 0854 | EMail:- ross.rosswalker.co.uk |

| http://www.rosswalker.co.uk | PGP Key available on request |



Note: Electronic Mail is not secure, has no guarantee of delivery, may not

be read every day, and should not be used for urgent or sensitive issues.



  

-----Original Message-----

From: owner-amber.scripps.edu

[mailto:owner-amber.scripps.edu] On Behalf Of Syed Tarique Moin

Sent: Tuesday, June 12, 2007 01:05

To: amber.scripps.edu

Subject: Re: AMBER: problem in installing amber9



Hi



Thanks for you kind suggestion,



But i want to update with amber9, so plz guide me for

the installation,



I have compiler g98 and the Hardware is Intel Xeon

dual processor.



Regard

--- "David A. Case" <mailto:case.scripps.edu> <case.scripps.edu> wrote:



    

On Fri, Jun 01, 2007, Syed Tarique Moin wrote:



      

I installed amber9 but not looking fine, i have a

problem in xleap, that when i make initial files,

        

like

      

using the command



solvatebox or addions the solvent surrounding the

solute not well file (file attached name as

amber9.jpg)



but its looking right with amber7.jpg (for the

comparison) surrounding the solute very well by

        

the

      

solvent.



        

Please see if this helps:



   

http://amber.ch.ic.ac.uk/archive/200406/0298.html



or this:



   http://amber.ch.ic.ac.uk/archive/200503/0122.html



or this:



   http://amber.ch.ic.ac.uk/archive/200610/0205.html



Since Amber 7 works, you can still use that, I would

imagine. You might

provide details about your compiler and what

architecture (emt64?) you are

using.



....dac





      

--------------------------------------------------------------

---------

    

The AMBER Mail Reflector

To post, send mail to amber.scripps.edu

To unsubscribe, send "unsubscribe amber" to

majordomo.scripps.edu



      

Syed Tarique Moin,

Junior Research Fellow,

H.E.J. Research Institute of Chemistry,

International Center for Chemical and Biological Sciences,

University of Karachi, Karachi-75720, Pakistan



tarisyed.yahoo.com

tarisyed.hotmail.com





       

______________________________________________________________

______________________

Get the Yahoo! toolbar and be alerted to new email wherever

you're surfing.

http://new.toolbar.yahoo.com/toolbar/features/mail/index.php

--------------------------------------------------------------

---------

The AMBER Mail Reflector

To post, send mail to amber.scripps.edu

To unsubscribe, send "unsubscribe amber" to majordomo.scripps.edu



    





-----------------------------------------------------------------------

The AMBER Mail Reflector

To post, send mail to amber.scripps.edu

To unsubscribe, send "unsubscribe amber" to majordomo.scripps.edu



  





-----------------------------------------------------------------------
The AMBER Mail Reflector
To post, send mail to amber.scripps.edu
To unsubscribe, send "unsubscribe amber" to majordomo.scripps.edu
Received on Sun Jun 17 2007 - 06:07:09 PDT
Custom Search